debian/rules: switch to rules.MakeMaker.noxs
[liburi-template-perl.git] / debian / rules
index a3dd6b1..0db9c08 100644 (file)
@@ -3,9 +3,6 @@
 # packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
 # the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
 # be used freely wherever it is useful.
-#
-# It was later modified by Jason Kohles <email@jasonkohles.com>
-# http://www.jasonkohles.com/ to support Module::Build installed modules
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -26,42 +23,45 @@ build: build-stamp
 build-stamp:
        dh_testdir
 
-       $(PERL) Build.PL installdirs=vendor
-       OPTIMIZE="-Wall -O2 -g" $(PERL) Build
+       # Add commands to compile the package here
+       $(PERL) Makefile.PL INSTALLDIRS=vendor
+       $(MAKE)
+       $(MAKE) test
 
-       touch build-stamp
+       touch $@
 
 clean:
        dh_testdir
        dh_testroot
 
-       # Add commands to clean up after the build process here
-       [ ! -f Build ] || $(PERL) Build distclean
-
        dh_clean build-stamp install-stamp
 
-install: build install-stamp
-install-stamp:
+       # Add commands to clean up after the build process here
+       [ ! -f Makefile ] || $(MAKE) realclean
+
+install: install-stamp
+install-stamp: build-stamp
        dh_testdir
        dh_testroot
        dh_clean -k
 
-       $(PERL) Build test
-       $(PERL) Build install destdir=$(TMP)
+       # Add commands to install the package into $(TMP) here
+       $(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
+
+       [ ! -d $(TMP)/usr/lib/perl5 ] || rmdir --ignore-fail-on-non-empty --parents --verbose $(TMP)/usr/lib/perl5
 
-       touch install-stamp
+       touch $@
 
 binary-arch:
-# We have nothing to do by default.
+# We have nothing to do here for an architecture-independent package
 
 binary-indep: build install
        dh_testdir
        dh_testroot
-       dh_installdocs
-       dh_installchangelogs
+       dh_installexamples
+       dh_installdocs README
+       dh_installchangelogs Changes
        dh_perl
-       dh_link
-       dh_strip
        dh_compress
        dh_fixperms
        dh_installdeb