0.13-2: fix perl 5.10 builds
[libwww-opensearch-perl.git] / debian / rules
index bf116f4..315f549 100755 (executable)
@@ -43,10 +43,7 @@ install-stamp:
        $(MAKE) test
        $(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
 
-       # As this is a architecture independent package, we are not
-       # supposed to install stuff to /usr/lib. MakeMaker creates
-       # the dirs, we delete them from the deb:
-       rmdir --ignore-fail-on-non-empty --parents $(TMP)/usr/lib/perl5
+       [ ! -d $(TMP)/usr/lib/perl5 ] || rmdir --ignore-fail-on-non-empty --parents --verbose $(TMP)/usr/lib/perl5
 
        touch install-stamp