0.13-2: fix perl 5.10 builds
[libwww-opensearch-perl.git] / debian / rules
old mode 100644 (file)
new mode 100755 (executable)
index e7865d5..315f549
@@ -1,8 +1,6 @@
 #!/usr/bin/make -f
-# This debian/rules file is provided as a template for normal perl
-# packages. It was created by Marc Brockschmidt <marc@dch-faq.de> for
-# the Debian Perl Group (http://pkg-perl.alioth.debian.org/) but may
-# be used freely wherever it is useful.
+# Debian Customisations Copyright 2006 Ian Beckwith <ianb@nessie.mcc.ac.uk>
+# Based on a template by Marc Brockschmidt <marc@dch-faq.de>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -11,7 +9,7 @@
 # always return the default without waiting for user input.
 export PERL_MM_USE_DEFAULT=1
 
-PACKAGE=$(shell dh_listpackages)
+PACKAGE=libwww-opensearch-perl
 
 ifndef PERL
 PERL = /usr/bin/perl
@@ -23,9 +21,8 @@ build: build-stamp
 build-stamp:
        dh_testdir
 
-       # Add commands to compile the package here
        $(PERL) Makefile.PL INSTALLDIRS=vendor
-       $(MAKE) OPTIMIZE="-Wall -O2 -g"
+       $(MAKE) 
 
        touch build-stamp
 
@@ -33,7 +30,6 @@ clean:
        dh_testdir
        dh_testroot
 
-       # Add commands to clean up after the build process here
        [ ! -f Makefile ] || $(MAKE) realclean
 
        dh_clean build-stamp install-stamp
@@ -44,14 +40,10 @@ install-stamp:
        dh_testroot
        dh_clean -k
 
-       # Add commands to install the package into debian/$PACKAGE_NAME here
        $(MAKE) test
        $(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
 
-       # As this is a architecture independent package, we are not
-       # supposed to install stuff to /usr/lib. MakeMaker creates
-       # the dirs, we delete them from the deb:
-       rmdir --ignore-fail-on-non-empty --parents $(TMP)/usr/lib/perl5
+       [ ! -d $(TMP)/usr/lib/perl5 ] || rmdir --ignore-fail-on-non-empty --parents --verbose $(TMP)/usr/lib/perl5
 
        touch install-stamp
 
@@ -61,14 +53,10 @@ binary-arch:
 binary-indep: build install
        dh_testdir
        dh_testroot
-#      dh_installcron
-#      dh_installmenu
-#      dh_installexamples
        dh_installdocs README
        dh_installchangelogs Changes
        dh_perl
        dh_link
-       dh_strip
        dh_compress
        dh_fixperms
        dh_installdeb
@@ -76,8 +64,5 @@ binary-indep: build install
        dh_md5sums
        dh_builddeb
 
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary