debian/rules: support DEB_BUILD_OPTIONS=nocheck
[libwww-opensearch-perl.git] / debian / rules
old mode 100644 (file)
new mode 100755 (executable)
index bf116f4..ac51683
@@ -40,13 +40,13 @@ install-stamp:
        dh_testroot
        dh_clean -k
 
+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
        $(MAKE) test
+endif
+
        $(MAKE) install DESTDIR=$(TMP) PREFIX=/usr
 
-       # As this is a architecture independent package, we are not
-       # supposed to install stuff to /usr/lib. MakeMaker creates
-       # the dirs, we delete them from the deb:
-       rmdir --ignore-fail-on-non-empty --parents $(TMP)/usr/lib/perl5
+       [ ! -d $(TMP)/usr/lib/perl5 ] || rmdir --ignore-fail-on-non-empty --parents --verbose $(TMP)/usr/lib/perl5
 
        touch install-stamp