pty: Activate the signature wrapper of forkpty.
[gnulib.git] / build-aux / gcc-warning.spec
1 # options to filter out, and why
2 --all-warnings                          alias for -Wall
3 --extra-warnings                        alias for -Wextra
4 -Waggregate-return                      obsolescent
5 -Waliasing                              fortran
6 -Walign-commons                         fortran
7 -Wampersand                             fortran
8 -Warray-temporaries                     fortran
9 -Wassign-intercept                      objc/objc++
10 -Wc++-compat                            FIXME maybe? borderline.  some will want this
11 -Wc++0x-compat                          c++
12 -Wc++11-compat                          c++
13 -Wc-binding-type                        fortran
14 -Wc-binding-type                        fortran
15 -Wcast-qual                             FIXME maybe? too much noise; encourages bad changes
16 -Wcharacter-truncation                  fortran
17 -Wcompare-reals                         fortran
18 -Wconversion                            FIXME maybe? too much noise; encourages bad changes
19 -Wconversion-extra                      fortran
20 -Wconversion-null                       c++ and objc++
21 -Wctor-dtor-privacy                     c++
22 -Wdeclaration-after-statement           FIXME: do not want.  others may
23 -Wdeclaration-after-statement           obsolescent
24 -Wdelete-non-virtual-dtor               c++
25 -Weffc++                                c++
26 -Werror-implicit-function-declaration   deprecated
27 -Wfloat-equal                           FIXME maybe? borderline.  some will want this
28 -Wformat                                covered by -Wformat=2
29 -Wformat=                               gcc --help=warnings artifact
30 -Wfunction-elimination                  fortran
31 -Wimplicit-interface                    fortran
32 -Wimplicit-procedure                    fortran
33 -Wintrinsic-shadow                      fortran
34 -Wintrinsics-std                        fortran
35 -Winvalid-offsetof                      c++ and objc++
36 -Wlarger-than-                          gcc --help=warnings artifact
37 -Wlarger-than=<number>                  FIXME: choose something sane?
38 -Wline-truncation                       fortran
39 -Wliteral-suffix                        c++ and objc++
40 -Wliteral-suffix                        c++ and objc++
41 -Wlong-long                             obsolescent
42 -Wnoexcept                              c++
43 -Wnon-template-friend                   c++
44 -Wnon-virtual-dtor                      c++
45 -Wnormalized=<id|nfc|nfkc>              FIXME: choose something sane?
46 -Wold-style-cast                        c++ and objc++
47 -Woverloaded-virtual                    c++
48 -Wpadded                                FIXME: dunno
49 -Wpadded                                FIXME maybe?  warns about "stabil" member in /usr/include/bits/timex.h
50 -Wpedantic                              FIXME: too strict?
51 -Wpmf-conversions                       c++ and objc++
52 -Wproperty-assign-default               objc++
53 -Wprotocol                              objc++
54 -Wreal-q-constant                       fortran
55 -Wrealloc-lhs                           fortran
56 -Wrealloc-lhs                           fortran
57 -Wrealloc-lhs-all                       fortran
58 -Wrealloc-lhs-all                       fortran
59 -Wredundant-decls                       FIXME maybe? many _gl_cxxalias_dummy FPs
60 -Wreorder                               c++ and objc++
61 -Wselector                              objc and objc++
62 -Wsign-compare                          FIXME maybe? borderline.  some will want this
63 -Wsign-conversion                       FIXME maybe? borderline.  some will want this
64 -Wsign-promo                            c++ and objc++
65 -Wstack-usage=                          FIXME: choose something sane?
66 -Wstrict-aliasing=                      FIXME: choose something sane?
67 -Wstrict-null-sentinel                  c++ and objc++
68 -Wstrict-overflow=                      FIXME: choose something sane?
69 -Wstrict-selector-match                 objc and objc++
70 -Wsurprising                            fortran
71 -Wswitch-enum                           FIXME maybe? borderline.  some will want this
72 -Wsynth                                 deprecated
73 -Wtabs                                  fortran
74 -Wtarget-lifetime                       fortran
75 -Wtraditional                           obsolescent
76 -Wtraditional-conversion                obsolescent
77 -Wundeclared-selector                   objc and objc++
78 -Wundef                                 FIXME maybe? too many false positives
79 -Wunderflow                             fortran
80 -Wunsuffixed-float-constants            triggers warning in gnulib's timespec.h
81 -Wunused-dummy-argument                 fortran
82 -Wuseless-cast                          c++ and objc++
83 -Wuseless-cast                          c++ and objc++
84 -Wzero-as-null-pointer-constant         c++ and objc++
85 -frequire-return-statement              go