switch to format 3.0 (quilt)
[ckermit.git] / debian / rules
index 447524e..3a38db2 100755 (executable)
@@ -2,7 +2,7 @@
 # -*- makefile -*-
 # debian/rules for ckermit
 # GNU copyright 1997 to 1999 by Joey Hess.
-# modified for ckermit by Ian Beckwith <ianb@nessie.mcc.ac.uk>
+# modified for ckermit by Ian Beckwith <ianb@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -20,17 +20,13 @@ else
        CFLAGS += -O2
 endif
 
-MAKEOPTS=-f makefile DESTDIR=\"$(BUILDDIR)\" BINDIR=/usr/bin MANDIR=/usr/share/man/man1 INFODIR=/usr/share/doc/ckermit KFLAGS='$(CFLAGS)' LNKFLAGS="-lsocksd -Wl,-z,defs -Wl,--as-needed"
+MAKEOPTS=-f makefile DESTDIR=\"$(BUILDDIR)\" BINDIR=/usr/bin MANDIR=/usr/share/man/man1 INFODIR=/usr/share/doc/ckermit KFLAGS='$(CFLAGS)' LNKFLAGS="-lsocks -Wl,-z,defs -Wl,--as-needed"
 
 #MAKETARGET=linux+krb5+krb4+openssl+shadow+pam
 MAKETARGET=linux+shadow+pam
 
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
-       INSTALL_PROGRAM += -s
-endif
-
 configure: configure-stamp
-configure-stamp:
+configure-stamp: patch
        dh_testdir
 
        touch configure-stamp
@@ -45,7 +41,7 @@ build-stamp: configure-stamp
 
        touch build-stamp
 
-clean:
+clean: unpatch
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp