dh_installchangelogs: use ckc300.txt; actually commit debian/patches/series removal
[ckermit.git] / debian / rules
old mode 100644 (file)
new mode 100755 (executable)
index b945e34..6757c3b
@@ -1,18 +1,20 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# debian/rules for ckermit
-# GNU copyright 1997 to 1999 by Joey Hess.
-# modified for ckermit by Ian Beckwith <ianb@nessie.mcc.ac.uk>
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+# modified for ckermit by Ian Beckwith <ianb@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 BUILDDIR=`pwd`/debian/ckermit
 
-CFLAGS = -g -DCK_SYSINI=\\\"/etc/kermit/kermrc\\\"    \
-            -DIKSDCONF=\\\"/etc/kermit/iksd.conf\\\"  \
-            -DOPENSSL_097 -DCK_INI_B -DTIMEH -DCK_SOCKS \
-                       -DX509_SUBJECT_ALT_NAME_TO_USER
+CFLAGS =-g \
+       -DIKSDCONF=\\\\\\\\\\\\\\\"/etc/kermit/iksd.conf\\\\\\\\\\\\\\\"  \
+       -DCK_SYSINI=\\\\\\\\\\\\\\\"/etc/kermit/kermrc\\\\\\\\\\\\\\\"  \
+       -DCK_INI_B -DX509_SUBJECT_ALT_NAME_TO_USER
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -20,51 +22,22 @@ else
        CFLAGS += -O2
 endif
 
-MAKEOPTS=-f makefile DESTDIR=\"$(BUILDDIR)\" BINDIR=/usr/bin MANDIR=/usr/share/man/man1 INFODIR=/usr/share/doc/ckermit KFLAGS='$(CFLAGS)' LNKFLAGS="-lsocksd"
+MAKEOPTS=-f makefile DESTDIR=\"$(BUILDDIR)\" BINDIR=/usr/bin MANDIR=/usr/share/man/man1 INFODIR=/usr/share/doc/ckermit KFLAGS='$(CFLAGS)' LNKFLAGS="-Wl,-z,defs -Wl,--as-needed"
+MAKETARGET=linux+krb5+openssl
 
-#MAKETARGET=linux+krb5+krb4+openssl+shadow+pam
-MAKETARGET=linux+shadow+pam
+%:
+       dh $@
 
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
-       INSTALL_PROGRAM += -s
-endif
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-
-       # Add here commands to compile the package.
+override_dh_auto_build:
        $(MAKE) $(MAKEOPTS) $(MAKETARGET)
 
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-
-       # Add here commands to clean up after the build process.
-       -$(MAKE) $(MAKEOPTS) clean
-       -rm -f wermit # no longer cleaned by upstream makefile
-       -rm -f UNINSTALL 
-       dh_clean 
+override_dh_auto_clean:
+       $(MAKE) $(MAKEOPTS) clean
+       rm -f wermit # no longer cleaned by upstream makefile
+       rm -f UNINSTALL
+       dh_clean
 
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
-
-       # Add here commands to install the package into debian/ckermit.
+override_dh_auto_install:
        $(MAKE) $(MAKEOPTS) install
        # move aside full config file (later linked to by dh_link)
        mv "$(BUILDDIR)/usr/bin/ckermit.ini" "$(BUILDDIR)/etc/kermit/kermrc.full"
@@ -76,41 +49,8 @@ install: build
        # duplicated in /usr/share/doc/ckermit/copyright
        rm "$(BUILDDIR)/usr/share/doc/ckermit/COPYING.TXT"
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+override_dh_installchangelogs:
+       dh_installchangelogs -k ckc300.txt
 
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs -k ckc211.txt
-       dh_installdocs
-#      dh_installexamples
-       dh_installdirs 
-#      dh_install
-       dh_installmenu
-       dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
+override_dh_installpam:
        dh_installpam --name=kermit
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_perl
-#      dh_python
-       dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure