use minimal dh rules file
[ckermit.git] / debian / rules
index 1c6f21d..7c0be03 100755 (executable)
@@ -1,7 +1,9 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# debian/rules for ckermit
-# GNU copyright 1997 to 1999 by Joey Hess.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
 # modified for ckermit by Ian Beckwith <ianb@debian.org>
 
 # Uncomment this to turn on verbose mode.
@@ -21,44 +23,22 @@ else
        CFLAGS += -O2
 endif
 
-#MAKEOPTS=-f makefile DESTDIR=\"$(BUILDDIR)\" BINDIR=/usr/bin MANDIR=/usr/share/man/man1 INFODIR=/usr/share/doc/ckermit KFLAGS='$(CFLAGS)' LNKFLAGS="-lsocks -lutil -Wl,-z,defs -Wl,--as-needed"
-
 MAKEOPTS=-f makefile DESTDIR=\"$(BUILDDIR)\" BINDIR=/usr/bin MANDIR=/usr/share/man/man1 INFODIR=/usr/share/doc/ckermit KFLAGS='$(CFLAGS)' LNKFLAGS="-lsocks -Wl,-z,defs -Wl,--as-needed"
 MAKETARGET=linux+krb5+openssl
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp
-       dh_testdir
+%:
+       dh $@
 
+override_dh_auto_build:
        $(MAKE) $(MAKEOPTS) $(MAKETARGET)
 
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-
+override_dh_auto_clean:
        $(MAKE) $(MAKEOPTS) clean
        rm -f wermit # no longer cleaned by upstream makefile
        rm -f UNINSTALL
        dh_clean
 
-install: build
-       dh_testdir
-       dh_testroot
-       dh_prep
-       dh_installdirs
-
-       # Add here commands to install the package into debian/ckermit.
+override_dh_auto_install:
        $(MAKE) $(MAKEOPTS) install
        # move aside full config file (later linked to by dh_link)
        mv "$(BUILDDIR)/usr/bin/ckermit.ini" "$(BUILDDIR)/etc/kermit/kermrc.full"
@@ -70,32 +50,8 @@ install: build
        # duplicated in /usr/share/doc/ckermit/copyright
        rm "$(BUILDDIR)/usr/share/doc/ckermit/COPYING.TXT"
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
+override_dh_installchangelogs:
        dh_installchangelogs -k ckc299.txt
-       dh_installdocs
-       dh_installdirs
-       dh_installmenu
-       dh_installdebconf
-       dh_installpam --name=kermit
-       dh_installman
-       dh_lintian
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+override_dh_installpam:
+       dh_installpam --name=kermit