use dh_prep instead of dh_clean -k
[ckermit.git] / debian / rules
index 1cf881c..e9faea2 100755 (executable)
@@ -2,13 +2,11 @@
 # -*- makefile -*-
 # debian/rules for ckermit
 # GNU copyright 1997 to 1999 by Joey Hess.
-# modified for ckermit by Ian Beckwith <ianb@nessie.mcc.ac.uk>
+# modified for ckermit by Ian Beckwith <ianb@debian.org>
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-include /usr/share/quilt/quilt.make
-
 BUILDDIR=`pwd`/debian/ckermit
 
 CFLAGS = -g -DCK_SYSINI=\\\"/etc/kermit/kermrc\\\"    \
@@ -28,7 +26,7 @@ MAKEOPTS=-f makefile DESTDIR=\"$(BUILDDIR)\" BINDIR=/usr/bin MANDIR=/usr/share/m
 MAKETARGET=linux+shadow+pam
 
 configure: configure-stamp
-configure-stamp: patch
+configure-stamp:
        dh_testdir
 
        touch configure-stamp
@@ -43,7 +41,7 @@ build-stamp: configure-stamp
 
        touch build-stamp
 
-clean: unpatch
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
@@ -56,7 +54,7 @@ clean: unpatch
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
        # Add here commands to install the package into debian/ckermit.
@@ -86,6 +84,7 @@ binary-arch: build install
        dh_installdebconf
        dh_installpam --name=kermit
        dh_installman
+       dh_lintian
        dh_link
        dh_strip
        dh_compress